compiling error, missing file

For all things Churrera. ¿Estás haciendo un juego? ¿quieres proponer un cambio? ¿tienes alguna duda? ¡Cuéntanoslo!

Moderador: na_th_an

andydansby
Mensajes: 14
Registrado: Vie, 16 Dic 2016, 04:00

compiling error, missing file

Mensajepor andydansby » Vie, 13 Ene 2017, 12:35

Hello:

I encountered an error on trying to compile the Dogmole example found at http://www.mojontwins.com/colegas/dogmole128k--source-code-(english).zip just for testing to see how the process works. I encountered the error
$this->bbcode_second_pass_code('', 'Can't open config file {z88dk10}\lib\configzx.cfg')

I then tried to compile other examples to see if it was just in the Dogmole example and encountered the exact same error.

I used the z88dk10 archive. On looking through the directories, I cannot find the configzx.cfg file. Any help with this would be appreciated.

Thanks
Andy Dansby
Avatar de Usuario
na_th_an
Mensajes: 26413
Registrado: Vie, 09 Ene 2009, 12:18

Re: compiling error, missing file

Mensajepor na_th_an » Sab, 14 Ene 2017, 10:27

It seems there's something really weird going on. The correct path should be

C:\z88dk10\lib\config\zx.cfg

Notice the extra "\" between config and zx. It seems there's something wrong with your installation. Are you using Windows? The Linux package was maintained by a fellow forum member and we have nothing to do with it so I cannot help you if that's the case :-(
Como diría Rorshach: "Urm..."
andydansby
Mensajes: 14
Registrado: Vie, 16 Dic 2016, 04:00

Re: compiling error, missing file

Mensajepor andydansby » Sab, 14 Ene 2017, 12:57

Yes, I am using Windows 10. I do have an installation of z88 as well on my HDD (Hopefully, this is not what is causing issues).

I just now modified my make.bat to include at the start.

$this->bbcode_second_pass_code('', '
echo ### set paths ###
SET Z80_OZFILES = C: \ z88dk10 \ Lib \
SET ZCCCFG = C: \ z88dk10 \ Lib \ Config \
SET PATH =% PATH% C:\z88dk10\Bin ; C:\z88dk10\include\ ; C:\z88dk10
')


I'm getting a little closer, however, I'm getting an error with SP1

$this->bbcode_second_pass_code('', '
C:\z88dk10\Dogmole128K (English)\dev>make
### set paths ###
### COMPILING SCRIPT ###
msc-config.h
msc.h
2 file(s) copied.
-------------------------------------------------------------------------------
### GENERATING BINARIES ###
* Building relocate
* Building RAM3 AND RAM4 AND RAM6
THE LIBRARIAN

Processing list.txt
+ File title.bin
+ File marco.bin
+ File ending.bin
Writing RAM3.bin
1 file(s) copied.
1 file(s) copied.
-------------------------------------------------------------------------------
### COMPILING WYZ PLAYER ###
1 file(s) copied.
-------------------------------------------------------------------------------
### COMPILING GAME ###
1 file(s) copied.
1 file(s) copied.
cpp: line 7, Fatal error: Cannot open include file "spritepack.h"
#include <spritepack.h>
-------------------------------------------------------------------------------
### BUILDING TAPE ###

BAS2TAP v2.5 by Martijn van der Heide of ThunderWare Research Center

Creating output file loader.tap
Done! Listing contains 1 line.
Input file open failed!
loader.tap
screen.tap
reubica.tap
ram1.tap
ram3.tap
1 file(s) copied.
-------------------------------------------------------------------------------
### LIMPIANDO ###
Could Not Find C:\z88dk10\Dogmole128K (English)\dev\main.tap
Could Not Find C:\z88dk10\Dogmole128K (English)\dev\dogmole.bin
-------------------------------------------------------------------------------
### DONE ###
')
andydansby
Mensajes: 14
Registrado: Vie, 16 Dic 2016, 04:00

Re: compiling error, missing file

Mensajepor andydansby » Sab, 14 Ene 2017, 15:58

I might have this figured out. I was able to compile correctly

in the make.bat file

I added
$this->bbcode_second_pass_code('', '
echo ### set paths ###
SET Z80_OZFILES = C:\z88dk10\lib\
SET ZCCCFG = C:\z88dk10\lib\config\
SET PATH =% PATH% C:\z88dk10\Bin;
SET PATH =% PATH% C:\z88dk10\include\;
SET PATH =% PATH% C:\z88dk10\;
SET PATH =% PATH% C:\z88dk10\lib\;
SET PATH =% PATH% C:\z88dk10\lib\config\;
')

At the just below

$this->bbcode_second_pass_code('', '@echo off')

and above $this->bbcode_second_pass_code('', 'echo ### COMPILING SCRIPT ###')


in the z88dk10 directory

I copied zx.cfg from C:\z88dk10\lib\config to C:\z88dk10\lib and then renamed zx.cfg to configzx.cfg

I then went to the \Dogmole128K (English)\dev directory and ran make.bat

It compiled and ran ok.

I was also able to do the same with the Ninjajar example and it seemed to play ok, although I'm not very good at playing the game, so I didn't make it too far. I might just have to recompile where I don't lose life for further testing.

Andy Dansby

Volver a “La Churrera”

¿Quién está conectado?

Usuarios navegando por este Foro: Bing [Bot] y 8 invitados